您的位置:首页 > 其它

hdu 1010 Tempter of the Bone(dfs)

2013-07-09 14:04 337 查看

Tempter of the Bone

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 51110 Accepted Submission(s): 13746

[/b]

Problem Description

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the
T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for
more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the
maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;

'S': the start point of the doggie;

'D': the Door; or

'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0


Sample Output

NO
YES


Author

ZHANG, Zheng

Source

ZJCPC2004

Recommend

JGShining

题意:由S走到D,X为不可行,必须在 t 步行到
题解:dfs+奇偶剪枝....注意输入格式啊....

#include<stdio.h>
#include<string.h>
int n,m,t,flag,finx,finy;
char c[10][10];
int ABS(int a)
{
return a>0?a:-a;
}
void dfs(int x,int y,int time)
{
if(c[x][y]=='X'||time>t||flag) return;
if(c[x][y]=='D')
{
if(time==t) flag=1;
return;
}
if((t-time-ABS(finx-x)-ABS(finy-y))&1) return;  //奇偶剪纸,为毛用ABS呢...本人的cb有问题...abs用不了...
c[x][y]='X';
if(y>1) dfs(x,y-1,time+1);
if(x<n) dfs(x+1,y,time+1);
if(y<m) dfs(x,y+1,time+1);
if(x>1) dfs(x-1,y,time+1);
c[x][y]='.';
}
int main()
{
int i,j,stax,stay;
char s[15];

while(scanf("%d%d%d",&n,&m,&t)>0)
{
if(n==0&&m==0&&t==0) break;
for(i=1;i<=n;i++)
{
scanf("%s",s);  //反正我是在输入这里wa了...
for(j=1;j<=m;j++)
{
c[i][j]=s[j-1];
if(c[i][j]=='S') stax=i,stay=j;
if(c[i][j]=='D') finx=i,finy=j;
}
}
flag=0,dfs(stax,stay,0);
if(flag) printf("YES\n");
else printf("NO\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: