您的位置:首页 > 其它

pku 2481 Cows(树状数组)

2013-07-08 16:05 239 查看
Cows

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 9966Accepted: 3264
Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a
range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input
3
1 2
0 3
3 4
0


Sample Output
1 0 0


Hint

Huge input and output,scanf and printf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

题意:给定每只牛有一个区间,求该牛的区间是多少只牛的区间的真子集

题解:原来这题用的是树状数组经典的思想,将区间排序,优先第一个元素有小到大,然后优先第二个元素由大到小,然后按这个顺序插入树状数组的话,就可以保证是之前的子集了,然后要稍微作处理才是真子集,详细见代码

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct point{
int st,en,id,res;
}p[100005];
int cc[100005];
int cmp(const void *a,const void *b)
{
struct point *c=(struct point *)a;
struct point *d=(struct point *)b;
if(c->st==d->st) return d->en-c->en;
return c->st-d->st;
}
int cmp2(const void *a,const void *b)
{
struct point *c=(struct point *)a;
struct point *d=(struct point *)b;
return c->id-d->id;
}
int low_bit(int x)
{
return x&(-x);
}
void add(int x)
{
while(x<100001)
{
cc[x]++;
x+=low_bit(x);
}
}
int sum(int x)
{
int temp=0;
while(x>0)
{
temp+=cc[x];
x-=low_bit(x);
}
return temp;
}
int main()
{
int n,i,temp1,temp2,cou;

while(scanf("%d",&n),n)
{
for(i=0;i<n;i++)
{
scanf("%d%d",&p[i].st,&p[i].en);
p[i].st++,p[i].en++;
p[i].id=i,p[i].res=0;
}
qsort(p,n,sizeof(p[0]),cmp);
memset(cc,0,sizeof(cc));
p[0].res=cou=0;
temp1=p[0].st,temp2=p[0].en;
add(p[0].en);
for(i=1;i<n;i++)
{
if(temp1==p[i].st&&temp2==p[i].en) cou++; //取出相等的区间集合,使res保存真子集数
else temp1=p[i].st,temp2=p[i].en,cou=0;
p[i].res=i-sum(p[i].en-1)-cou;
add(p[i].en);
}
qsort(p,n,sizeof(p[0]),cmp2);
for(i=0;i<n-1;i++) printf("%d ",p[i].res);
printf("%d\n",p[i].res);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: