您的位置:首页 > 其它

zoj--1089--Lotto---DFS VS 暴力求解

2013-07-08 16:03 351 查看
LottoTime Limit: 2 Seconds Memory Limit: 65536 KB
In a Lotto I have ever played, one has to select 6 numbers from the set {1,2,...,49}. A popular strategy to play Lotto - although it doesn't increase your chance of winning - is to select a subset S containing k (k>6) of these 49 numbers, and then play several games with choosing numbers only from S. For example, for k=8 and S = {1,2,3,5,8,13,21,34} there are 28 possible games: [1,2,3,5,8,13], [1,2,3,5,8,21], [1,2,3,5,8,34], [1,2,3,5,13,21], ... [3,5,8,13,21,34].

Your job is to write a program that reads in the number k and the set S and then prints all possible games choosing numbers only from S.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing several integers separated from each other by spaces. The first integer on the line will be the number k (6 < k < 13). Then k integers, specifying the set S, will follow in ascending order. Input will be terminated by a value of zero (0) for k.

Output Specification

For each test case, print all possible games, each game on one line. The numbers of each game have to be sorted in ascending order and separated from each other by exactly one space. The games themselves have to be sorted lexicographically, that means sorted by the lowest number first, then by the second lowest and so on, as demonstrated in the sample output below. The test cases have to be separated from each other by exactly one blank line. Do not put a blank line after the last test case.

Sample Input

7 1 2 3 4 5 6 7
8 1 2 3 5 8 13 21 34
0

Sample Output

1 2 3 4 5 6
1 2 3 4 5 7
1 2 3 4 6 7
1 2 3 5 6 7
1 2 4 5 6 7
1 3 4 5 6 7
2 3 4 5 6 7

1 2 3 5 8 13
1 2 3 5 8 21
1 2 3 5 8 34
1 2 3 5 13 21
1 2 3 5 13 34
1 2 3 5 21 34
1 2 3 8 13 21
1 2 3 8 13 34
1 2 3 8 21 34
1 2 3 13 21 34
1 2 5 8 13 21
1 2 5 8 13 34
1 2 5 8 21 34
1 2 5 13 21 34
1 2 8 13 21 34
1 3 5 8 13 21
1 3 5 8 13 34
1 3 5 8 21 34
1 3 5 13 21 34
1 3 8 13 21 34
1 5 8 13 21 34
2 3 5 8 13 21
2 3 5 8 13 34
2 3 5 8 21 34
2 3 5 13 21 34
2 3 8 13 21 34
2 5 8 13 21 34
3 5 8 13 21 34


//方法1:在poj的discuss里看到的暴强代码:6层循环
#include<stdio.h>//全排列,层循环,强大啊,因为k比较小。太NB了
#include <string.h>
int main()
{
int i,a1,a2,a3,a4,a5,a6,k;
int a[14];
scanf("%d",&k);
while(1)
{
if(k==0) break;
for(i=0;i<k;i++) scanf("%d",&a[i]);
for(a1=0;a1<k-5;a1++)
for(a2=a1+1;a2<k-4;a2++)
for(a3=a2+1;a3<k-3;a3++)
for(a4=a3+1;a4<k-2;a4++)
for(a5=a4+1;a5<k-1;a5++)
for(a6=a5+1;a6<k;a6++)
printf("%d %d %d %d %d %d\n",a[a1],a[a2],a[a3],a[a4],a[a5],a[a6]);
scanf("%d",&k);
if(k)
printf("\n");
}
return 0;
}

//方法2:一般做法,dfs
#include <stdio.h>
int k,a[14],b[7];
void dfs(int len,int current)
{
int i;
if(len>6)
{
for(i=1;i<6;i++)
{
printf("%d ",b[i]);
}
printf("%d\n",b[i]);
}
else
{
for(i=current;i<k-(6-len)+1;i++)//这里的循环,确定i的范围并赋值
{
b[len]=a[i];
dfs(len+1,i+1);
}
}
}
int main()
{

int i;
scanf("%d",&k);
while(1)
{
if(k==0) break;
for(i=1;i<=k;i++)
scanf("%d",&a[i]);
dfs(1,1);
scanf("%d",&k);
if(k) printf("\n");
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: