您的位置:首页 > 其它

南华大学ACM第一场个人联系赛 A Eming

2013-07-08 07:19 381 查看
Eming
   

   Eming is a contest hold by WHUACM training team. The aim is to select new members of the team.

   Usually, the first problem is a very simple problem such as “a+b problem”. But this time, Xioumu is tired of this kind of problem, he decide to solve “a and b problem”.

   Give you the result of a + b and a^2 – b^2, please output the result of a and b.

 

   Input

   There are several test cases. For each case there are two double numbers indicating a+b and a^2-b^2. You may assume that a+b will not be zero.

 

   Output

   For each case please output the result of a and b in one line, rounded to 2 decimal places.

 

   Sample Input

   3 -3

 

   Sample Output

   1.00 2.00

 

仔细读懂题意,题目说要求两个浮点数,且告诉了你两个数的和及两个数的平方差,即(a+b,和a^2-b^2),那么这个可以用解方程组的方法来解决,假设m=a+b,n=a^2-b^2,则可以解得a=(m+n/m)/2,,b=(m-n/m)/2.然后就是保留两个小数就好了。

下面是我的代码:

#include<iostream>

#include<iomanip>

using namespace std;

int main()

{

    double m,n;

    double a,b;

    while(cin>>m>>n)

    {

        a=(m+n/m)/2;

        b=(m-n/m)/2;

        cout<<setprecision(2)<<fixed<<a<<" "<<b<<endl;

    }

    return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: