您的位置:首页 > 其它

pku 1511 Invitation Cards(最短路径)

2013-07-06 23:38 225 查看
Invitation Cards

Time Limit: 8000MSMemory Limit: 262144K
Total Submissions: 16309Accepted: 5310
Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information
and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special
course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait
until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting
and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program
that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number
of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which
is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input
2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50


Sample Output
46
210


Source

Central Europe 1998
题意:有n个点m条有向边,求由点1到其他点的最短路径和加上其他点到点1的最短路径和

题解:由于是稀疏图,用静态邻接表存图,用spfa算法....原图求一次最短路,将所有边的方向置反再求一次.....(ps:由于本人爱c 300年,所以语言是c,队列部分是模拟的,没用stl)

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define INF 1<<30
struct linjiebiao{
int data,l,next;
}v1[1000005],v2[1000005];
int p1[1000005],p2[1000005],n,insert1,insert2;
int que[2000005],mark[1000005],dis1[1000005],dis2[1000005];
void init()
{
int i;

for(i=0;i<=n;i++)
{
dis1[i]=dis2[i]=INF;
p1[i]=p2[i]=-1;
}
insert1=insert2=dis1[1]=dis2[1]=0;
}
void add1(int x,int y,int l)
{
v1[insert1].next=p1[x];
v1[insert1].data=y;
v1[insert1].l=l;
p1[x]=insert1++;
}
void add2(int x,int y,int l)
{
v2[insert2].next=p2[x];
v2[insert2].data=y;
v2[insert2].l=l;
p2[x]=insert2++;
}
void spfa1()
{
int sta=0,fin=1,x,i,temp;

for(i=0;i<=n;i++) mark[i]=0;
que[0]=mark[1]=1;
while(sta<fin)
{
x=que[sta++];
mark[x]=0;
temp=p1[x];
while(temp!=-1)
{
if(dis1[v1[temp].data]>dis1[x]+v1[temp].l)
{
dis1[v1[temp].data]=dis1[x]+v1[temp].l;
if(!mark[v1[temp].data])
{
mark[v1[temp].data]=1;
que[fin++]=v1[temp].data;
}
}
temp=v1[temp].next;
}
}
}
void spfa2()
{
int sta=0,fin=1,x,i,temp;

for(i=0;i<=n;i++) mark[i]=0;
que[0]=mark[1]=1;
while(sta<fin)
{
x=que[sta++];
mark[x]=0;
temp=p2[x];
while(temp!=-1)
{
if(dis2[v2[temp].data]>dis2[x]+v2[temp].l)
{
dis2[v2[temp].data]=dis2[x]+v2[temp].l;
if(!mark[v2[temp].data])
{
mark[v2[temp].data]=1;
que[fin++]=v2[temp].data;
}
}
temp=v2[temp].next;
}
}
}
int main()
{
int i,t,m,x,y,l;
__int64 sum;

scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
init();
for(i=0;i<m;i++)
{
scanf("%d%d%d",&x,&y,&l);
add1(x,y,l),add2(y,x,l);
}
spfa1(),spfa2();
for(sum=0,i=2;i<=n;i++) sum+=dis1[i]+dis2[i];
printf("%I64d\n",sum);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: