您的位置:首页 > 移动开发

pku 3321 Apple Tree(dfs+树状数组)

2013-07-06 10:58 375 查看
Apple Tree

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 15686Accepted: 4679
Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the
same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?



Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.

The following N - 1 lines each contain two integers u and v, which means fork u and fork v are
connected by a branch.

The next line contains an integer M (M ≤ 100,000).

The following M lines each contain a message which is either

"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.

or

"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x

Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input
3
1 2
1 3
3
Q 1
C 2
Q 1


Sample Output
3
2


Source

POJ Monthly--2007.08.05, Huang, Jinsong

题意:一课树上面有苹果,一开始全部结点都有苹果,通过一些结点苹果是否有取反,问你这个结点的子树有多少个苹果。

题解:标准解法是dfs+树状数组,但是我特意去写了一下vector做邻接表,妥妥的超时....于是就慢慢码邻接表了....方法是,将树的每一个结点分成2个点用dfs存入数组....规则是子树的所有结点必须包含在父节点两端点的中间....例如ABBCCA代表B和C是A的子结点。

然后在这个数组基础上建立树状数组,算出来的数除以2就是结果

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct NEXT{
int num;
struct NEXT *next;
}v[100005],*p,*q;
int s[100005],f[100005],cou,n;
int cc[200005],mark[200005];
void dfs(int x)
{
int i,temp;
struct NEXT *p;

mark[x]=1,s[x]=cou++;
if(v[x].num>0) p=v[x].next;
for(i=0;i<v[x].num;i++)
{
temp=p->num;
if(!mark[temp]) dfs(temp);
p=p->next;
}
f[x]=cou++;
}
int low_bit(int x)
{
return x&(-x);
}
void updata(int x,int y)
{
while(x<=2*n)
{
cc[x]+=y;
x+=low_bit(x);
}
}
int sum(int x)
{
int temp=0;
while(x>0)
{
temp+=cc[x];
x-=low_bit(x);
}
return temp;
}
int main()
{
int x,y,i,temp,m;
char ch;

scanf("%d",&n);
for(i=1;i<=n;i++)
{
v[i].num=0;
v[i].next=NULL;
}
for(i=1;i<n;i++)
{
scanf("%d%d",&x,&y);
p=(struct NEXT *)malloc(sizeof(struct NEXT));
p->next=NULL,p->num=y;
if(v[x].num==0) v[x].next=p;
else
{
q=v[x].next;
while(q->next!=NULL) q=q->next;
q->next=p;
}
v[x].num++;

}
memset(mark,0,sizeof(mark));
cou=1,dfs(1);
memset(mark,1,sizeof(mark));
memset(cc,0,sizeof(cc));
for(i=1;i<=2*n;i++) updata(i,1);
scanf("%d",&m);
for(i=0;i<m;i++)
{
getchar();
scanf("%c%d",&ch,&temp);
if(ch=='C')
{
if(mark[s[temp]])
{
updata(s[temp],-1);
updata(f[temp],-1);
mark[s[temp]]=mark[f[temp]]=0;
}
else
{
updata(s[temp],1);
updata(f[temp],1);
mark[s[temp]]=mark[f[temp]]=1;
}
}
else
{
x=s[temp],y=f[temp];
temp=sum(y)-sum(x-1);
printf("%d\n",temp/2);
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: