您的位置:首页 > 其它

poj 2184 Cow Exhibition(01背包)

2013-07-06 09:45 399 查看
Cow Exhibition

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7595Accepted: 2751
Description
"Fat and docile, big and dumb, they look so stupid, they aren't much

fun..."

- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input
* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output
8

Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF

= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value

of TS+TF to 10, but the new value of TF would be negative, so it is not

allowed.

题意:给出n个物品的si值和fi值,要求取若干个物品,使得si的总和>0,fi的总和>0,且si的总和+fi的总和最大。
思路:01背包的变形。设dp[i]表示si的总和为i时fi的最大值。因为si有负值,我们可以进行扩展。因为si最大为1000,最多有100个,总共为100000,将所有值+100005.

AC代码:
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <iostream>

using namespace std;
const int base=100005;
const int INF=-100000000;
int main()
{
int n;
int s[105],f[105];
int dp[200100];
cin>>n;
for(int i=0;i<n;i++)
{
cin>>s[i]>>f[i];
}
for(int i=0;i<=base*2;i++)
dp[i]=INF;
dp[base]=0;
for(int i=0;i<n;i++)
{
if(s[i]<0&&f[i]<0) continue;
if(s[i]<0)
{
for(int j=0;j<=base*2+s[i];j++)      //s[i]为负值,要从小到大搜
if(dp[j-s[i]]>INF)                   //表示可以达到这个值
dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
}
else
{
for(int j=base*2;j>=s[i];j--)       //s[i]为正值,就是普通的01背包。
if(dp[j-s[i]]>INF)
dp[j]=max(dp[j],dp[j-s[i]]+f[i]);
}
}
int ans=base;
for(int i=base;i<=base*2;i++)        //从base开始搜,因为<base的s[i]都为负值
if(dp[i]>0&&dp[i]+i>ans) ans=dp[i]+i;

cout<<ans-base<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: