您的位置:首页 > 产品设计 > UI/UE

uva 12167 - Proving Equivalences(强连通缩点,4级)

2013-07-04 21:46 330 查看
Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

A is invertible.
Ax = b has exactly one solution for every n × 1 matrix b.
Ax = b is consistent for every n × 1 matrix b.
Ax = 0 has only the trivial solution x = 0.


The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies
(a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires
proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.
m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies
statement s2.

Output

Per testcase:

One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2
4 0
3 2
1 2
1 3


Sample Output

4
2


The 2008 ACM Northwestern European Programming Contest

思路:标准的模板题。判断缩点后0出度点数和0入度的点数取大的值,就是答案。

//69MS
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int mm=2e4+9;
const int mn=5e4+9;
int head[mm];
class node
{
public:int v,next;
}e[mn],cun[mn];
int dfn[mm],ii[mm],oo[mm],edge;

int dfs_clock,bcc_no,n,m;
int e_to[mm],stak[mm],top;
int tarjan(int u)
{
int lowu,lowv,v;
lowu=dfn[u]=++dfs_clock;
stak[++top]=u;
for(int i=head[u];~i;i=e[i].next)
{
v=e[i].v;
if(!dfn[v])
{
lowv=tarjan(v);
lowu=min(lowu,lowv);

}else if(!e_to[v])
lowu=min(lowu,dfn[v]);
}
if(lowu>=dfn[u])
{
++bcc_no;
while(1)
{
v=stak[top--];
e_to[v]=bcc_no;
if(v==u)break;
}
}
return lowu;
}
void find_bcc()
{ memset(dfn,0,sizeof(dfn));
memset(e_to,0,sizeof(e_to));
top=dfs_clock=bcc_no=0;
for(int i=1;i<=n;++i)
if(!dfn[i])tarjan(i);
}
void data()
{
memset(head,-1,sizeof(head));edge=0;
}
void add(int u,int v)
{
e[edge].v=v;e[edge].next=head[u];head[u]=edge++;
}
int main()
{
int cas,a,b;
while(~scanf("%d",&cas))
{
while(cas--)
{ data();
scanf("%d%d",&n,&m);
for(int i=0;i<m;++i)
{
scanf("%d%d",&a,&b);
cun[i].next=a;cun[i].v=b;
add(a,b);
}
find_bcc();
int id=0,od=0;
int u,v;
memset(ii,0,sizeof(ii));
memset(oo,0,sizeof(oo));
for(int i=0;i<m;++i)
{ u=e_to[cun[i].next];v=e_to[cun[i].v];
if(u!=v)
oo[u]=1,ii[v]=1;
}
for(int i=1;i<=bcc_no;++i)
{if(!ii[i])++id;
if(!oo[i])++od;
}
int ans=max(id,od);
if(bcc_no==1)ans=0;
printf("%d\n",ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: