您的位置:首页 > 其它

HDU 1712 ACboy needs your help

2013-07-04 19:23 260 查看
Problem Description
ACboy has N courses this term,and he plans to spend at most M days on study.Of course,the profit he will gainfrom different course depending on the days he spend on it.How to arrange the Mdays for the N courses to
maximize the profit?
 
 
Input
The input consists of multipledata sets. A data set starts with a line containing two positive integers N andM, N is the number of courses, M is the days ACboy has.

Next follow a matrix A[i][j],(1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spendj days on ith course he will get profit of value A[i][j].

N = 0 and M = 0 ends the input.
 
 
Output
For each data set, yourprogram should output a line which contains the number of the max profit ACboywill gain.
 
 
Sample Input
2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0
 
 
Sample Output
3
4
6
 

题目简介:ACboy有n门课可以参加,他有m天时间。一天只能参加一门课。一门课可以参加多天,参加的天数不同获得的经验不一样。但是要注意的是,同一门课不是参加的天数越多,经验就越高。输入的表示是,行数表示第几门课,列数表示上几天,该数就是第几门课参加几天获得的经验数。问m天能获得最多的经验数。

方法:分组背包。状态转移方程为f[j]=max{f[j],f[j-k]+a[i][k]},意思是前j-k获得的经验数是f[j-k],后k天参加第i门课获得的经验是a[i][k]。比较此时的f[j]和f[j-k]+a[i][k]谁大。

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int f[101];

int main()
{
int m ,n;
int i ,j ,k;
int a[101][101];
while(scanf("%d%d",&n,&m),n+m!=0)
{
for(i = 1;i<=n;i++)
{
for(j = 1;j<=m;j++)
{
scanf("%d",&a[i][j]);
}
}

memset(f,0,sizeof(f));

for(i = 1;i<=n;i++)
{
for(j = m;j>=1;j--)
{
for(k = 1;k<=j;k++)
{
if(f[j] < f[j-k] + a[i][k])
{
f[j] = f[j-k] + a[i][k];
}
}
}
}
printf("%d\n",f[m]);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: