您的位置:首页 > 其它

hdu1071(定积分求面积)

2013-06-28 17:16 323 查看
太弱了,写了一下午,高中基础太差的孩子伤不起。。。

记住抛物线是关于x轴对称的。

而且抛物线的方程可以是: y=k(x-h)+c //其中(h,c)为顶点坐标

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6080 Accepted Submission(s): 4247


[align=left]Problem Description[/align]
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

[align=left]Output[/align]
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

[align=left]Sample Input[/align]

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

[align=left]Sample Output[/align]

33.33
40.69

Hint

For float may be not accurate enough, please use double instead of float.

[align=left]Author[/align]
Ignatius.L

#include <stdio.h>
#include <iostream>
using namespace std;
#define INF 0x3fffffff

double x1,y1;
double x2,y2;
double x3,y3;

int main()
{
//freopen("//home//chen//Desktop//ACM//in.text","r",stdin);
//freopen("//home//chen//Desktop//ACM//out.text","w",stdout);
int T;
scanf("%d",&T);

while(T--)
{
scanf("%lf%lf",&x1,&y1);
scanf("%lf%lf",&x2,&y2);
scanf("%lf%lf",&x3,&y3);
double a,b,c,k,d;
b=x1;
c=y1;
a=(y2-c)/( (x2-b)*(x2-b) );
k=(y3-y2)/(x3-x2);
d=y3-x3*k;
double ans=(a*(x3-b)*(x3-b)*(x3-b)/3)+c*x3-(k*x3*x3)/2-d*x3-( ( a*(x2-b)*(x2-b)*(x2-b))/3+c*x2-(k*x2*x2)/2-d*x2);
if(ans<0) ans*=-1;
printf("%.2lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: