您的位置:首页 > 其它

POJ 3264 Balanced Lineup

2013-06-25 20:52 267 查看
[align=center]Balanced Lineup[/align]

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 27620Accepted: 12987
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..
N+1: Line
i+1 contains a single integer that is the height of cow
i

Lines
N+2..
N+
Q+1: Two integers
A and
B (1 ≤
A ≤
B ≤
N), representing the range of cows from
A to
B inclusive.

Output

Lines 1..
Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver

RMQ算法模版题。注意运算符的优先级 1 + 1<<2 和1 + (1<<2)的结果是不一样的

同样1<<2 + 1 和(1<<2)+1的结果也是不一样的。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define N 51000
using namespace std;
int Max
[20],Min
[20],a
,n,m;
int main()
{
//freopen("data1.in","r",stdin);
void RMQ_init();
void RMQ(int l,int r,int &res1,int &res2);
while(scanf("%d %d",&n,&m)!=EOF)
{
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
RMQ_init();
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d %d",&x,&y);
int res1,res2;
RMQ(x,y,res1,res2);
printf("%d\n",res2 - res1);
}
}
return 0;
}
void RMQ_init()
{
for(int i=1;i<=n;i++)
{
Max[i][0] = a[i];
Min[i][0] = a[i];
}
for(int j=1;(1<<j)<=n;j++)
{
for(int i=1;i +(1<<(j-1))<=n;i++)
{
Min[i][j] = min(Min[i][j-1],Min[i +(1<<(j-1))][j-1]);
Max[i][j] = max(Max[i][j-1],Max[i +(1<<(j-1))][j-1]);
}
}
}
void RMQ(int l,int r,int &res1,int &res2)
{
int k = 0;
while(1<<(k+1)<=(r - l + 1))
{
k++;
}
res1 = min(Min[l][k],Min[r -(1<<k)+1][k]);
res2 = max(Max[l][k],Max[r -(1<<k)+1][k]);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: