您的位置:首页 > 其它

poj 1456 Supermarket(贪心+并查集,贪心+优先队列)

2013-06-23 22:24 471 查看
Supermarket

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 7677Accepted: 3252
Description
A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes
precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit
of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts
at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.



Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input
A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling
deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
Output
For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
Sample Input
4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
5 20  50 10

Sample Output
80
185

Hint
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

题意:有n个商品,每个商品都有相应的价值pi和卖出去的最后期限di,每天只能卖一件商品。求最多能获得的价值。
思路:贪心法。

法一:并查集优化:枚举每个商品,找出最接近该商品最后期限的未被占用的一天来卖该商品。而要找出这一天可以用到并查集来快速查找。
AC代码:
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>

using namespace std;
struct node
{
int pi,di;
}pro[10005];
int fa[10005];
bool cmp(node a,node b)
{
return a.pi>b.pi;
}
void init()
{
for(int i=1;i<=10005;i++)
fa[i]=i;
}
int Find_set(int x)
{
if(x==fa[x]) return x;
fa[x]=Find_set(fa[x]);
return fa[x];
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d%d",&pro[i].pi,&pro[i].di);
sort(pro,pro+n,cmp);
init();
int sum=0;
for(int i=0;i<n;i++)
{
int rt=Find_set(pro[i].di);
if(rt>0)
{
sum+=pro[i].pi;
fa[rt]=rt-1;
}
}
printf("%d\n",sum);
}
return 0;
}


法二:优先队列优化
AC代码:
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>

using namespace std;
struct node
{
int pi,di;
}pro[10005];
int fa[10005];
bool cmp(const node& p1,const node& p2){
return p1.di<p2.di;
}
bool operator < (const node& p1,const node& p2){
return p2.pi<p1.pi;
}
int main()
{
int n;
priority_queue<node>q;
while(scanf("%d",&n)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%d%d",&pro[i].pi,&pro[i].di);
sort(pro,pro+n,cmp);
int sum=0;
for(int i=0;i<n;i++)
{
if(pro[i].di>q.size())
{
q.push(pro[i]);
}
else if(pro[i].pi>q.top().pi)
{
q.pop();
q.push(pro[i]);
}
}
while(!q.empty())
{
sum+=q.top().pi;
q.pop();
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: