您的位置:首页 > 产品设计 > UI/UE

poj 2264 Advanced Fruits

2013-06-20 23:18 183 查看
Advanced Fruits

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 1854Accepted: 919Special Judge
Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new
fruit emerges that tastes like a mixture between both of them.

A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string
that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file.
Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
Sample Input
apple peach
ananas banana
pear peach

Sample Output
appleach
bananas
pearch


合并两个字符串,最长公共子序列的应用,找出两个字符串的LCS,然后构造目标字符串。例如,有两个字符串
apple pffeach
这两个字符串的LCS是P E
那么分别找出P,E在两个字符串的位置,再将不属于LCS的字符插进来,就变成了:
(a) P   (pl) (ff) E (ach)


AC代码:

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>

using namespace std;

int main()
{
int dp[105][105];
string s1,s2,s;
while(cin>>s1>>s2)
{
memset(dp,0,sizeof(dp));
int len1=s1.length();
int len2=s2.length();
for(int i=1; i<=len1; i++)
for(int j=1; j<=len2; j++)
dp[i][j]=s1[i-1]==s2[j-1]?dp[i-1][j-1]+1:max(dp[i-1][j],dp[i][j-1]);
int i=len1,j=len2,t=0;
while(dp[i][j])
{
if(s1[i-1]==s2[j-1])
{
i--;
j--;
s[t++]=s1[i];
}
else if(dp[i-1][j]>dp[i][j-1])
{
i--;
s[t++]=s1[i];
}
else
{
j--;
s[t++]=s2[j];
}
}
while(i>=1) s[t++]=s1[--i];
while(j>=1) s[t++]=s2[--j];
s[t]=0;
for(i=t-1; i>=0; i--)
cout<<s[i];
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: