您的位置:首页 > 其它

HDU (1050) Moving Tables

2013-06-20 11:41 423 查看

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1050

[align=left]Problem Description[/align]
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

[align=left]Input[/align]
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each
of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the
same manner as above.

[align=left]Output[/align]
The output should contain the minimum time in minutes to complete the moving, one per line.

[align=left]Sample Input[/align]

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


[align=left]Sample Output[/align]

10
20
30


[align=left]Source[/align]
Asia 2001, Taejon (South Korea)

这是一个贪心的问题,可以用覆盖的方法去作吧!!即从哪里经过一次,哪里的标记数就加一,时间就是最大的标记数乘以10

AC代码:

#include <iostream>

#include<cstring>

using namespace std;

int a[1008];

int main()

{

int t,s,T,j,max,n,m;

cin>>T;

while(T--)

{

max=0;

memset(a,0,sizeof(a));

cin>>n;

while(n--)

{

cin>>s>>t;

if(s>t)

{

m=t;

t=s;

s=m;

}

s=(s+1)/2; //优化一下

t=(t+1)/2;

for(j=s;j<=t;j++) //统计出在某一点的最大数值

{

++a[j];

if(a[j]>max)

max=a[j];

}

}

cout<<max*10<<endl;

}

return 0;

}

路途中。。。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: