您的位置:首页 > 其它

杭电ACM HDU 2816 I Love You Too

2013-06-19 22:26 369 查看

I Love You Too

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1258 Accepted Submission(s): 759



Problem Description
This is a
true story. A man showed his love to a girl,but the girl didn't replied clearly ,just gave him a Morse Code:

****-/*----/----*/****-/****-/*----/---**/*----/****-/*----/-****/***--/****-/*----/----*/**---/-****/**---/**---/***--/--***/****-/ He was so anxious that he asked for help in the Internet and after one day a girl named "Pianyi angel" found
the secret of this code. She translate this code as this five steps:

1.First translate the morse code to a number string:4194418141634192622374

2.Second she cut two number as one group 41 94 41 81 41 63 41 92 62 23 74,according to standard Mobile phone can get this alphabet:GZGTGOGXNCS



3.Third she change this alphabet according to the keyboard:QWERTYUIOPASDFGHJKLZXCVBNM = ABCDEFGHIJKLMNOPQRSTUVWXYZ

So ,we can get OTOEOIOUYVL

4.Fourth, divide this alphabet to two parts: OTOEOI and
OUYVL
, compose again.we will get OOTUOYEVOLI

5.Finally,reverse this alphabet the answer will appear : I LOVE YOU TOO



I guess you might worship Pianyi angel as me,so let's Orz her.

Now,the task is translate the number strings.



Input
A number string each line(length <= 1000). I ensure all input are legal.



Output
An upper alphabet string.



Sample Input
4194418141634192622374
41944181416341926223




Sample Output
ILOVEYOUTOO
VOYEUOOTIO




Author
NotOnlySuccess



Source
HDU 1st “Old-Vegetable-Birds Cup” Programming Open Contest



Recommend
lcy


因为不仔细,WA了1次

#include<cstdio>
#include<cstring>
int turn(char c){
    int i;
    char key[30]={"QWERTYUIOPASDFGHJKLZXCVBNM"};
    for(i=0;i<26;i++)
        if(c==key[i])return i+65;
}
int main(){
    int a,i,l;
    char p[10][5]={"ABC","DEF","GHI","JKL","MNO","PQRS","TUV","WXYZ"};
    char num[1001],str1[501],str2[501];
    while(~scanf("%s",num)){
        l=strlen(num);
        for(i=0;i<l;i+=2){
            str1[i/2]=p[num[i]-50][num[i+1]-49];
        }
        for(i=0;i<l/2;i++)
            str1[i]=turn(str1[i]);
        for(i=(l/2+1)/2;i<=l/2;i++)
            str2[i-(l/2+1)/2]=str1[i];
        str1[(l/2+1)/2]=0;
        for(i=0;i<l/4+1;i++){
            num[i*2]=str1[i];
            num[i*2+1]=str2[i];
        }
        for(i=l/2-1;i>=0;i--)
            printf("%c",num[i]);
        printf("\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: