您的位置:首页 > 其它

ZOJ 1016 Parencodings (括号匹配) 思路

2013-06-14 18:17 246 查看
Parencodings

Time Limit: 1 Second      Memory
Limit: 32768 KB

Let S = s1 s2 ... s2n be a well-formed string of parentheses. S can be encoded in two different ways:

By an integer sequence P = p1 p2 ... pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).

By an integer sequence W = w1 w2 ... wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).

Following is an example of the above encodings:

S (((()()())))

P-sequence 4 5 6666

W-sequence 1 1 1456

Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed
string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2

6

4 5 6 6 6 6

9

4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6

1 1 2 4 5 1 1 3 9

题目大意:p串表示第i个右括号左边左括号的个数,w串表示第i个右括号包含多少已经匹配的括号,算上自己。

给出p序列,求w序列。

思路:用数组的下标表示括号序列的位置,里面存放数字代表左,右括号。

#include <stdio.h>
int main()
{/* test是测试的次数,a数组存放p串,b数组存放w串,n是输入的序列长度,visited数组代表以匹配标记,tt记录i个右括号包含多少已经匹配的括号*/
int n,test,a[50],i,num,j,visited[50],tt,m,b[50];
scanf("%d",&test);
while(test--)
{
scanf("%d",&n);
for(i=0;i<2*n;i++)
{
a[i]=0;   	  //以标志位的形式记录信息,1表示左括号,2表示右括号,0表示空。
visited[i]=0;  //记录已经匹配到的标志。1为匹配到,0为没有匹配到。
b[i]=0;
}
for(i=0;i<n;i++)
{
scanf("%d",&num);
a[num+i]=2;   //标记右括号为2 。加i表示算上已经标记过的右括号。

for(j=0;j<num+i;j++)  //初始化第 i个右括号,左边的所有左括号。
{
if(a[j]==0)     //在某个位置还未初始化的时候,才标记左括号。
a[j]=1;
}
}
m=0;
for(i=0;i<2*n;i++)
{
if(a[i]==2)  	//找到一个右括号,从右括号的前一个位置,从后往前匹配左括号。
{
tt=0;
for(j=i-1;j>=0;j--)
{
if(a[j]==1)   //只要找到一个匹配的左括号tt++ ,w串找的是已经匹配上的串和自己,只要发现左括号就++。

tt++;
if(a[j]==1&&visited[j]==0)  //当且仅当,找到左括号并且没有匹配过的左括号,才可以进行匹配。找到w串。
{
b[m++]=tt;
visited[j]=1;
break;
}
}
}
}
for(i=0;i<m-1;i++)  //输出w串
printf("%d ",b[i]);
printf("%d\n",b[i]);   //将最后一个数字放在这里输出,防止最后还有一个空格输出导致输出格式的错误
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: