您的位置:首页 > 其它

hdu 1163 Eddy's digital Roots (数根)

2013-06-14 13:46 459 查看

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3351 Accepted Submission(s): 1897



[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are
summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.

[align=left]Input[/align]
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

[align=left]Output[/align]
Output n^n's digital root on a separate line of the output.

[align=left]Sample Input[/align]

2
4
0


[align=left]Sample Output[/align]

4
4


[align=left]Author[/align]
eddy

[align=left]Recommend[/align]
JGShining

题解:这是一道经典的数根问题,首先要知道一个数论知识点,一个非零n进制数mod(n-1)的结果,若为0修正为n-1,这个结果和原来数的数根一样,证明略。

知道上述结论这道题目就很好做了,AC代码如下(c语言):

//不用快速幂的代码
#include <stdio.h>
#include <stdlib.h>
int main()
{
int n,i,res,mul;

while(scanf("%d",&n),n)
{
for(i=0,res=1,mul=n%9;i<n;i++)
res=mul*res%9;
res=res==0?9:res;
printf("%d\n",res);
}
return 0;
}

//用快速幂的代码,由于n很小,不用都能过
#include <stdio.h>
#include <stdlib.h>
int POW(int a,int b)
{
int res=1,mul=a;
while(b)
{
if(b&1) res=mul*res%9;
mul=mul*mul%9;
b=b>>1;
}
return res;
}
int main()
{
int n,res,m;

while(scanf("%d%d",&n,&m),n&&m)
{
res=POW(n,m);
res=res==0?9:res;
printf("%d\n",res);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: