您的位置:首页 > 其它

杭电ACM 1052(Tian Ji -- The Hor…

2013-06-13 15:37 363 查看
[align=left]Problem Description[/align]
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official
in the country Qi. He likes to play horse racing with the king and
others."

"Both of Tian and the king have three horses in different classes,
namely, regular, plus, and super. The rule is to have three rounds
in a match; each of the horses must be used in one round. The
winner of a single round takes two hundred silver dollars from the
loser."

"Being the most powerful man in the country, the king has so nice
horses that in each class his horse is better than Tian's. As a
result, each time the king takes six hundred silver dollars from
Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the
most famous generals in Chinese history. Using a little trick due
to Sun, Tian Ji brought home two hundred silver dollars and such a
grace in the next match."

"It was a rather simple trick. Using his regular class horse race
against the super class from the king, they will certainly lose
that round. But then his plus beat the king's regular, and his
super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself.
Even more, were he sitting in the ACM contest right now, he may
discover that the horse racing problem can be simply viewed as
finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever
one of Tian's horses can beat one from the king, we draw an edge
between them, meaning we wish to establish this pair. Then, the
problem of winning as many rounds as possible is just to find the
maximum matching in this graph. If there are ties, the problem
becomes more complicated, he needs to assign weights 0, 1, or -1 to
all the possible edges, and find a maximum weighted perfect
matching...

However, the horse racing problem is a very special case of
bipartite matching. The graph is decided by the speed of the horses
--- a vertex of higher speed always beat a vertex of lower speed.
In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this
special case of matching problem.

 

[align=left]Input[/align]
The input consists of up to 50 test cases. Each case starts
with a positive integer n (n <= 1000) on the first
line, which is the number of horses on each side. The next n
integers on the second line are the speeds of Tian’s horses. Then
the next n integers on the third line are the speeds of the king’s
horses. The input ends with a line that has a single 0 after the
last test case.

 

[align=left]Output[/align]
For each input case, output a line containing a single number,
which is the maximum money Tian Ji will get, in silver
dollars.

 

[align=left]Sample Input[/align]

3 92 83 71
95 87 74 2 20 20 20 20 2 20 19 22 18 0

 

[align=left]Sample Output[/align]

200 0
0

 

 
我的代码;
C++语言:


#include<stdio.h>
int
main()

int
n,s,i,j,sub=0,sum=0;
int
tfast,tslow,wfast,wslow; //分别代表田的最快马,最慢马,王的最快马,最慢马
int
t[1000],w[1000];

 while(scanf("%d",&n)&&(n!=0))

 {   

  for(i=0;i<n;i++)

   scanf("%d",&t[i]);

  for(i=0;i<n;i++)

   scanf("%d",&w[i]);

 for(i=0;i<n-1;i++)

  for(j=0;j<n-1-i;j++)

           if(t[j]&
4000
lt;t[j+1])

  {s=t[j];t[j]=t[j+1];t[j+1]=s;}

       for(i=0;i<n-1;i++)

  for(j=0;j<n-1-i;j++)

  if(w[j]<w[j+1])

  {s=w[j];w[j]=w[j+1];w[j+1]=s;}  //由大到小排序

    tfast=0;tslow=n-1;

    wfast=0;wslow=n-1;   //最快最慢马的初始化

   

   for(i=0;i<n;i++)        //分三种情况
{

    if(t[tfast]==w[wfast])   //情况1

 {

    if(t[tslow]>w[wslow]){sub++;tslow--;wslow--;}

    else
if(t[tslow]<w[wslow]){sub--;tslow--;wfast++;}

          else
if(t[tslow]==w[wslow])

    {

     if(t[tslow]<w[wfast]){sub--;tslow--;wfast++;}

              else
if(t[tslow]==w[wfast]){break;}

    }

 }

       else
if(t[tfast]>w[wfast])    //情况2

 {sub++;tfast++;wfast++;}

 else   {sub--;tslow--;wfast++;}
//情况3
}

  sum=sub*200;

  printf("%d\n",sum);

  sub=0;sum=0;

 }
}

 

 

 

 
田 的马 a……
b
王 的马
a1……b1

a=a1的情况分三种

1.b>b1 b与b1比较,+1

2.b<b1 b与a1比较,-1
3.b=b1
分两种情况

(1)b<a1,b与a1相比,-1

(2)b=a1,a1与b比较,之后的都是0

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: