您的位置:首页 > 其它

DFS+记忆搜索-HDU-1078

2013-06-12 19:22 441 查看


FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3404    Accepted Submission(s): 1348


Problem Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 

The input ends with a pair of -1's. 

 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

 

Sample Output

37

 

刚开始理解错题意了,以为可以同时向两个方向走,麻烦大了。

#include <iostream>
#include <stdio.h>
using namespace std;

int n, k, map[101][101], ans, opt[101][101];
int dir[4][2]={{1,0},{-1,0},{0,-1},{0,1}};//方向

int dfs(int x, int y) {
if(opt[x][y]) return opt[x][y];
int tmax = map[x][y];
for(int i=0; i<4; i++){
for(int j=1; j<=k; j++){
int tx = x+dir[i][0] * j;
int ty = y + dir[i][1] * j;
if(tx >=0 && tx <n && ty >=0 && ty < n && map[tx][ty] > map[x][y]){
int t = dfs(tx, ty) + map[x][y] ;
if(t > tmax) tmax = t;
}
}
}
return opt[x][y] = tmax;
}
int main() {
//freopen("in.txt", "r", stdin);
while (cin >> n >> k) {
if (n == -1)
break;
for (int i = 0; i < n; i++)
for (int j = 0; j < n; j++) {
cin >> map[i][j];
opt[i][j] = 0;
}
ans = 0;
ans = dfs(0, 0);
cout << ans << endl;

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: