您的位置:首页 > 其它

Hdu1084 What Is Your Grade?

2013-06-12 11:37 323 查看

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)



[align=left]Problem Description[/align]
“Point, point, life of student!”

This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.

There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only
when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.

Note, only 1 student will get the score 95 when 3 students have solved 4 problems.

I wish you all can pass the exam!

Come on!

 

[align=left]Input[/align]
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed
time). You can assume that all data are different when 0<p.

A test case starting with a negative integer terminates the input and this test case should not to be processed.

 

[align=left]Output[/align]
Output the scores of N students in N lines for each case, and there is a blank line after each case.

 

[align=left]Sample Input[/align]

4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

 

[align=left]Sample Output[/align]

100
90
90
95

100

 
题意:答题,根据学生的solve数目和solve时间给学生打分,solve5道题的得100分,solve nothing的得50分。4道题的得95或90,3道题的得85或80,2道题的得75或70,。。。
在答1,2,3,4道题的学生中时间排在前面一半的学生得高分,注意:只有一个学生解答一个数目的题目,他得高分;3个同学解答了同样数目的题,只有排在最前面的第一个得高分,剩下的两个都得低分。输出也要按输入的顺序。
 
代码:
#include<stdio.h>
#include<string.h>
struct node
{
int  solve;
char time[12];
int score;
}s[110];
int num[6];
int n;
int main()
{
while(~scanf("%d",&n) && n>0)
{
int i,j;
memset(num,0,sizeof(num));
for (i = 0; i < n; i++)
{
int x;
scanf("%d%s",&s[i].solve,s[i].time);
x = s[i].solve*10 + 50;
s[i].score = x;
if(s[i].solve < 5&&s[i].solve > 0)
{
++num[s[i].solve];
}
}
int low;
for (i = 0; i < n; i++)
{
low = 0;
if(num[s[i].solve])
{
for (j = 0; j < n; j++)
{
if( s[i].solve == s[j].solve && strcmp(s[i].time,s[j].time) > 0) low++;
}
if(num[s[i].solve]==1 || low < num[s[i].solve]/2)s[i].score +=5;
}
printf("%d\n",s[i].score);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM