您的位置:首页 > 其它

hdu 1052 Tian Ji -- The Horse Racing

2013-06-07 00:39 288 查看



Tian Ji -- The Horse Racing

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14135 Accepted Submission(s): 4010



Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers
on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0


Sample Output

200
0
0
题意:田忌赛马。给出田忌的马和齐王的马的速度。问田忌能赢几场。思路:贪心策略:可以分三种情况:1.田忌最慢的马比齐王最慢的马快:让两者比赛,赢一场。2.田忌最慢的马比齐王最慢的马慢:让田忌最慢的马和齐王最快的马比赛,输一场。因为始终田忌这匹马都要输,最优就是消耗掉齐王最快的马。3.田忌最慢的马和齐王最慢的马速度一样:这个又分三种情况(比较两者最快的马):(1)若田忌最快的马比齐王最快的马快:让两者比赛,赢一场。(2)若田忌最快的马比齐王最快的马慢:让[b]田忌最慢的马和齐王最快的马比赛,输一场。[/b][b](3)若田忌最快的马和齐王最快的马速度一样:[b]让田忌最慢的马和齐王最快的马比赛,输一场。[/b][/b][b][b]AC代码:[/b][/b]
#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdlib>

using namespace std;

int main()
{
int n;
int k[1005];
int t[1005];
while(cin>>n,n)
{
for(int i=0;i<n;i++)
cin>>t[i];
for(int i=0;i<n;i++)
cin>>k[i];
sort(k,k+n);
sort(t,t+n);
int j=0,win=0;
int kn=n;
for(int i=0;i<n;)
{
if(k[j]<t[i])
{
i++;
j++;
win++;
}
else if(k[j]>t[i])
{
kn--;
win--;
i++;
}
else if(k[j]==t[i])
{
if(t[n-1]>k[kn-1])
{
win++;
kn--;
n--;
}
else if(t[n-1]<k[kn-1])
{
i++;
win--;
kn--;
}
else if(t[n-1]==k[kn-1])
{
if(t[i]<t[n-1])
win--;
kn--;
i++;
}
}
}
cout<<win*200<<endl;
}
return 0;
}




[/b]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: