您的位置:首页 > 产品设计 > UI/UE

[ACM]Common Subsequence

2013-06-03 14:29 351 查看
[align=left]Problem Description[/align]
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 

 

[align=left]Sample Input[/align]

abcfbc abfcab
programming contest
abcd mnp

 

 

[align=left]Sample Output[/align]

4
2
0

 

解题思路:

横竖两轴分别为两字符串中的字符,其中里面的数字均是0,代码中有体现。然后从左上角填数字,对应位置如果有相同的字符,则本位置的数字等于相邻左上角的数字加1;

即当 s1[i]== s2 [j]  时, a[i][j]= a[i-1][j-1]+1  ,对应位置如果没有相同的字符,本位置的数字等于相邻左,上位置数字的最大值,即s1[i] != s2[j]时, a[i][j]= max(a[i-1] [j], a[i]  [j-1]),一直计算到,a[s1.length()] [ s2.length()] 位置,即为答案。

辅助图:



代码:

#include <iostream>
#include <string>
#define max 1000
using namespace std;
int a[max][max];
int max1(int x,int y)
{
int m;
m=x>y?x:y;
return m;
}//返回两个数最大值的函数
int main()
{

string s1,s2;
while(cin>>s1>>s2)
{
int i,j;
for(i=0;i<=s1.length();i++)
a[i][0]=0;
for(i=0;i<=s2.length();i++)
a[0][i]=0;//a数组上边左边数据初始化为0
for(i=1;i<=s1.length();i++)
for(j=1;j<=s2.length();j++)
{
if(s1[i-1]==s2[j-1])
a[i][j]=a[i-1][j-1]+1;
else
a[i][j]=max1(a[i-1][j],a[i][j-1]);
}
cout<<a[s1.length()][s2.length()]<<endl;
}
}


 

运行截图:

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: