您的位置:首页 > 其它

POJ 3067 Japan

2013-06-01 20:50 302 查看
[b]Japan[/b]

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16884Accepted: 4530
Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.
Output

For each test case write one line on the standard output:
Test case (case number): (number of crossings)
Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
题目大意:树状数组求逆序数


#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;
int M, N, K;
long long t[1010];

typedef struct node
{
int x;
int y;
}City;

City citys[1000010];

bool cmp(const City &city1, const City &city2)
{
if (city1.x == city2.x)
{
return city1.y < city2.y;
}
return city1.x < city2.x;
}

int lowbit(int x)
{
return x & -x;
}

void add(int pos, long long x)
{
while(pos <= N)
{
t[pos] += x;
pos += lowbit(pos);
}
}

int getsum(int pos)
{
int sum = 0;
while(pos > 0)
{
sum += t[pos];
pos -= lowbit(pos);
}
return sum;
}

int main()
{
long long result = 0;
int n;
scanf("%d", &n);
for (int i = 1; i <= n; i++)
{
result = 0;
scanf("%d%d%d", &M, &N, &K);
for (int j = 0; j < K; j++)
{
scanf("%d%d", &citys[j].x, &citys[j].y);
}
sort(citys, citys + K, cmp);
memset(t, 0, sizeof(t));
for (int j = 0; j < K; j++)
{
result += getsum(N) - getsum(citys[j].y);
add(citys[j].y, 1);
}
printf("Test case %d: %I64d\n", i, result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: