您的位置:首页 > 其它

Uva 10014

2013-06-01 19:48 411 查看
Simple calculations

The Problem

There is a sequence of n+2 elements a0, a1,…, an+1 (n <= 3000; -1000 <= ai 1000). It is known that ai = (ai–1 + ai+1)/2 – ci for each i=1, 2, ..., n. You are given a0, an+1, c1, ... , cn. Write a program which calculates a1.

The Input

The first line is the number of test cases, followed by a blank line. For each test case, the first line of an input file contains an integer n. The next two lines consist of numbers a0 and an+1 each having two digits after decimal point, and the next n lines contain numbers ci (also with two digits after decimal point), one number per line.
Each test case will be separated by a single line.

The Output

For each test case, the output file should contain a1 in the same format as a0 and an+1. Print a blank line between the outputs for two consecutive test cases.

Sample Input

1

1
50.50
25.50
10.15

Sample Output

27.85
#include<stdio.h>
#include<string.h>

int main()
{
    int T, n, i;
    double first, final, sum, temp, ans;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        scanf("%lf", &first);
        scanf("%lf", &final);
        for(i=1,sum=0; i<=n; ++i)
        {
            scanf("%lf", &temp);
            sum += 2.0*(n+1-i)*temp;
        }
        
        ans = n*first+final-sum;
        printf("%.2lf\n", ans/(n+1));
        
        if(T != 0) printf("\n");
    }
    return 0;
}







内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: