您的位置:首页 > 其它

uva573(数学)

2013-05-30 10:57 337 查看
http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&category=7&problem=514&mosmsg=Submission+received+with+ID+10536992

573 - The Snail

Time limit: 3.000 seconds

The Snail
A snail is at the bottom of a 6-foot well and wants to climb to
the top. The snail can climb 3 feet while the sun is up, but slides
down 1 foot at night while sleeping. The snail has a fatigue factor
of 10%, which means that on each successive day the snail climbs
10%

3 = 0.3 feet less than it did the previous day. (The
distance lost to fatigue is always 10% of thefirst day's
climbing distance.) On what day does the snail leave the well,
i.e., what is the first day during which the snail's
height exceeds 6 feet? (A day consists of a period of
sunlight followed by a period of darkness.) As you can see from the
following table, the snail leaves the well during the third
day.

DayInitial HeightDistance ClimbedHeight After ClimbingHeight After Sliding
10'3'3'2'
22'2.7'4.7'3.7'
33.7'2.4'6.1'-
Your job is to solve this problem in general. Depending on the
parameters of the problem, the snail will eventually either leave
the well or slide back to the bottom of the well. (In other words,
the snail's height will exceed the height of the well or become
negative.) You must find out which happens first and on what
day.

Input

The input file contains one or more test cases, each on a line
by itself. Each line contains four integers H, U,
D, and F, separated by a single space. If H= 0
it signals the end of the input; otherwise, all four numbers will
be between 1 and 100, inclusive. H is the height of the well
in feet, U is the distance in feet that the snail can climb
during the day,D is the distance in feet that the snail
slides down during the night, and F is the fatigue factor
expressed as a percentage. The snail never climbs a
negative distance. If the fatigue factor drops the snail's climbing
distance below zero, the snail does not climb at all that day.
Regardless of how far the snail climbed, it always slides D
feet at night.

Output

For each test case, output a line indicating whether the snail
succeeded (left the well) or failed (slid back to the bottom) and
on what day. Format the output exactly as shown in the
example.

Sample Input

6 3 1 10
10 2 1 50
50 5 3 14
50 6 4 1
50 6 3 1
1 1 1 1
0 0 0 0

Sample Output

success on day 3
failure on day 4
failure on day 7
failure on day 68
success on day 20
failure on day 2



题意:给测试数据,H,U,D,F。H表示墙的高度,U表示白天能爬多少,D表示晚上下降多少,F表示疲劳程序(表示每天爬的高度都会减少H*F%)。注意,蜗牛是不会往下爬的,白天能爬的距离小于0,那么它是会保持原来的高度,然后晚上下降D。要求输出,在第几天爬出,或者在第几天掉回原点。回到原点,是高度小于0(关键)

#include<stdio.h>

#include<string.h>

int main()

{

double h,u,d,f;

while(scanf("%lf",&h)!=EOF)

{

if(h==0)

break;

scanf("%lf%lf%lf",&u,&d,&f);

int days=1;

double hight=0.0;

double D=f/100.0*u;

while(1)

{

if(u>=0.0)

{

hight+=u;

if(hight>h)

{

printf("success
on day %d\n",days);

break;

}

}

hight=hight-d;

u=u-D;

if(hight<0)

{

printf("failure
on day %d\n",days);

break;

}

days++;

}



}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: