您的位置:首页 > 其它

poj1163(DP)and3176(DP)多串的…

2013-05-30 10:50 337 查看
http://poj.org/problem?id=3176
Cow Bowling

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10012Accepted: 6594
Description

The cows don't use
actual bowling balls when they go bowling. They each take a number
(in the range 0..99), though, and line up in a standard
bowling-pin-like triangle like this:

7

        3   8

      8   1   0

    2   7   4   4

  4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and
moving "down" to one of the two diagonally adjacent cows until the
"bottom" row is reached. The cow's score is the sum of the numbers
of the cows visited along the way. The cow with the highest score
wins that frame.

Given a triangle with N (1 <= N <=
350) rows, determine the highest possible sum achievable.
Input

Line 1: A single
integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that
represent row i of the triangle.
Output

Line 1: The largest
sum achievable using the traversal rules
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the
sample:

7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5

The highest score is achievable by traversing the cows as shown
above.
Source

USACO 2005 December Bronze
这题白皮书上第7章上有

#include<stdio.h>

#include<string.h>

int map[500][500],dp[500][500],n;

int max(int a,int b)

{

return a>b?a:b;

}

int d(int i,int j)

{

if(dp[i][j]>=0)return
dp[i][j];

return
dp[i][j]=map[i][j]+(i==n-1?0:max(d(i+1,j),d(i+1,j+1)));

}

int main()

{

while(scanf("%d",&n)!=EOF)

{

int i,j;

for(i=0;i<n;i++)

for(j=0;j<=i;j++)

scanf("%d",&map[i][j]);

memset(dp,-1,sizeof(dp));

printf("%d\n",d(0,0));

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: