您的位置:首页 > 其它

Leftmost Digit

2013-05-27 23:50 591 查看
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1788 Accepted Submission(s): 801
 
[align=left]Problem Description[/align]
Given a positive integer N, you should output the leftmost digit of N^N.

 
[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

 
[align=left]Output[/align]
For each test case, you should output the leftmost digit of N^N.

 
[align=left]Sample Input[/align]

2
3
4


 
[align=left]Sample Output[/align]

2
2

<div style="" border-bottom:="" #b7cbff="" 1px="" dashed;="" border-left:="" padding-bottom:="" 6px;="" padding-left:="" padding-right:="" font-family:="" times"="">
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

 
[align=left]Author[/align]
Ignatius.L
对一个数num可写为 num=10n * a,  即科学计数法,使a的整数部分即为num的最高位数字

numnum=10n * a  这里的n与上面的n不等

两边取对数: num*lg(num) = n + lg(a);

因为a<10,所以0<lg(a)<1

令x=n+lg(a); 则n为x的整数部分,lg(a)为x的小数部分

又x=num*lg(num);

a=10(x-n)  =  10(x-int(x)))

再取a的整数部分即得num的最高位

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int t,n;
while(~scanf("%d",&t))
{
while(t--)
{
scanf("%d",&n);
double x=n*log10(1.0*n);
x=x-(__int64)x;
int a=pow(10.0,x);
printf("%d\n",a);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 公式法 数论 水题