您的位置:首页 > 其它

动态规划1-Robberies-POJ-2955

2013-05-27 10:48 363 查看


Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7107    Accepted Submission(s): 2666


Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before
retiring to a comfortable job at a university.



For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line
j gives an integer Mj and a floating point number Pj . 

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

 

Sample Output

2
4
6

这里涉及到概率的问题,而不是简单的相加。可以计算逃脱的概率,这样是连续相乘的,相对方便一些。

和平常的01背包问题有些差别,这里用  

opt[j] 表示在获得金钱j时最大的逃脱概率

最后,在找出满足要求的最大j。

#include <iostream>
using namespace std;

int marr[101];
double parr[101];
int k,n;
double up;
int ans;
double opt[100001]; // opt[j] 表示在获得金钱j时最大的逃脱概率
int sum;
int main() {
cin >> k;
while(k--){
double tb;
cin >> up >> n;
sum = 0;
for(int i=0; i<n; i++){
// 计算所有银行金钱的和
cin >> marr[i] >> parr[i];
sum += marr[i];
}
opt[0] = 1.0;
for(int i=1; i<=sum; i++)
opt[i] = 0.0;
for(int i=0; i<n; i++){
for(int j=sum; j>=marr[i]; j--){
tb = opt[ j-marr[i] ] * (1-parr[i]);
if(tb > opt[j])
opt[j] = tb;
}
}

for(int i=sum; i>=0; i--){ //遍历,找到满足要求的最大金钱数
if(1-opt[i] <= up){
cout << i << endl;
break;
}
}

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: