您的位置:首页 > 编程语言 > C语言/C++

poj 1163 The Triangle

2013-05-25 00:00 211 查看
摘要: 上课dp例题。。dp不会写,做例题找找感觉。ps.没有用滚动数组,用滚动数组还可减少空间消耗

/*The Triangle
Time Limit: 1000MS		Memory Limit: 10000K
Total Submissions: 32748		Accepted: 19386

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that
starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally
down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle.
The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The
numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Source
IOI 1994*/

#include <cstdio>
using namespace std;
int main()
{
int n = 0, max = 0;
int tri[105][105] = {0};
int dis[105][105] = {0};
scanf("%d", &n);
for(int i = 0; i < n; ++i)
for(int j = 0; j <= i; ++j)
scanf("%d", &tri[i][j]);
dis[0][0] = tri[0][0];
if(n > 1)
{
for(int i = 1; i < n; ++i)
{
dis[i][0] = tri[i][0] + dis[i - 1][0];
dis[i][i] = tri[i][i] + dis[i - 1][ i - 1];
}
if(n > 2)
{for(int i = 2; i < n; ++i)
for(int j = 1; j < i; ++j)
{
if(dis[i - 1][j - 1] > dis[i - 1][j]) dis[i][j] = tri[i][j] + dis[i - 1][j - 1];
else dis[i][j] = tri[i][j] + dis[i - 1][j];
}}
}
/*for(int i = 0; i < n; ++i)
{
for(int j = 0; j <= i; ++j)
printf("%d ", dis[i][j]);
printf("\n");
}*/
for(int j = 0; j < n; ++j)
{
if(dis[n - 1][j] > max) max = dis[n - 1][j];
}
printf("%d\n", max);
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj cpp