您的位置:首页 > 大数据 > 人工智能

hdu 4300 Clairewd’s message(扩展KMP)

2013-05-22 20:28 190 查看

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2305 Accepted Submission(s): 905



[align=left]Problem Description[/align]
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another
one according to a conversion table.

Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action,
she just stopped transmitting messages.

But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering
the shortest possible text is not a hard task for you.

Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

[align=left]Input[/align]
The first line contains only one integer T, which is the number of test cases.

Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the
text is complete.

Hint
Range of test data:

T<= 100 ;

n<= 100000;

[align=left]Output[/align]
For each test case, output one line contains the shorest possible complete text.

[align=left]Sample Input[/align]

2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde


[align=left]Sample Output[/align]

abcdabcd
qwertabcde


[align=left]Author[/align]
BUPT

[align=left]Source[/align]
2012 Multi-University Training Contest 1

思路:用扩展KMP 求出明文串的匹配串长。输出。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int mm=1e5+9;
char s[mm],t[mm];
int has[155];
int next[mm],ex[mm];
void getnext(const char*t)
{ int len=strlen(t);
next[0]=len;
int a=0;
while(a<len-1&&t[a]==t[a+1])++a;
next[1]=a;
int l,le;a=1;
for(int i=2;i<len;++i)
{
le=a+next[a]-1;///a影响断范围
l=next[i-a];///已经确定断匹配
if(le<=i-1+l)
{ int j=le-i+1>0?le-i+1:0;
while(i+j<len&&t[i+j]==t[j])++j;
next[i]=j;a=i;
}else next[i]=l;
}
}
void ekmp(const char*s,const char*t)
{ getnext(t);
int a=0,ls,lt;ls=strlen(s);lt=strlen(t);
while(a<ls&&a<lt&&s[a]==t[a])++a;
ex[0]=a;a=0;
int l,le;
for(int i=1;i<ls;++i)
{
le=ex[a]+a-1;l=next[i-a];///已经确定的匹配
if(le<=l+i-1)
{
int j=le-i+1>0?le-i+1:0;
while(i+j<ls&&j<lt&&s[i+j]==t[j])++j;
ex[i]=j;a=i;
}
else ex[i]=l;
}
}
int main()
{ int cas;
while(~scanf("%d",&cas))
{ while(cas--)
{scanf("%s",s);
memset(has,0,sizeof(has));
for(int i=0;s[i];++i)
has[s[i]]=i+'a';
scanf("%s",s);
for(int i=0;s[i];++i)
t[i]=has[s[i]];
int len=strlen(s);
t[len]='\0';
ekmp(s,t);
///for(int i=0;i<len;++i)
//cout<<ex[i]<<" ";
///cout<<endl;
bool yes=0;
for(int i=0;s[i];++i)
{
if(i+ex[i]==len&&i>=ex[i])
{ //cout<<s<<endl;
//cout<<i<<endl;
yes=1;
for(int j=0;j<i;++j)printf("%c",s[j]);
for(int j=0;j<i;++j)printf("%c",has[s[j]]);
puts("");
break;
}
}
if(!yes)
{
for(int j=0;j<len;++j)printf("%c",s[j]);
for(int j=0;j<len;++j)printf("%c",has[s[j]]);
puts("");
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: