您的位置:首页 > 其它

poj_1716Integer Intervals

2013-05-22 19:26 393 查看
Integer Intervals
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11782 Accepted: 4964
DescriptionAn integer interval [a,b], a < b, is a set of all consecutive integers beginning with a and ending with b. Write a program that: finds the minimal number of elements in a set containing at least two different integers from each interval.InputThe first line of the input contains the number of intervals n, 1 <= n <= 10000. Each of the following n lines contains two integers a, b separated by a single space, 0 <= a < b <= 10000. They are the beginning and the end of an interval.OutputOutput the minimal number of elements in a set containing at least two different integers from each interval.Sample Input
4
3 6
2 4
0 2
4 7
Sample Output
4
#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<cmath>
#include<vector>
#include<algorithm>
#include<set>
#include<string>
#include<queue>
#include <stack>
using namespace std;
#pragma warning(disable : 4996)
const int MAXN = 10005;
const int INF = 999999;

typedef struct Node
{
int v;//终点位置
int value;//权值
int next;//同一起点下在edge数组中的位置
}Node;
Node edge[MAXN * 4];//邻接表
int first[MAXN];//以该点为起点的第一条边在edge数组中的位置
int n; //n点数
bool visited[MAXN];
int dist[MAXN];
queue<int>Q;
int MIN, MAX;

void init()
{
int x, y, index;
memset(first, -1, sizeof(first));
index = 1;
MIN = INF;
MAX = -INF;
for (int i = 1; i <= n; i++)
{
scanf("%d %d", &x, &y);
y++;
if(x < MIN)
{
MIN = x;
}
if(y > MAX)
{
MAX = y;
}
edge[index].v = y;
edge[index].value = 2;
edge[index].next = first[x];
first[x] = index++;
}
//cout << MIN << " " << MAX << endl;
for (int i = MIN; i < MAX; i++)
{
edge[index].v = i + 1;
edge[index].value = 0;
edge[index].next = first[i];
first[i] = index++;

edge[index].v = i;
edge[index].value = -1;
edge[index].next = first[i + 1];
first[i + 1] = index++;
}

}

void SPFA(int Start)
{
while (!Q.empty())
{
Q.pop();
}
for (int i = 0; i <= MAX; i++)
{
visited[i] = false;
dist[i] = -INF;
}
dist[Start] = 0;
visited[Start] = true;
Q.push(Start);
while (!Q.empty())
{
int top = Q.front();
Q.pop();
visited[top] = false;
for (int i = first[top]; i != -1 ; i = edge[i].next)
{
int e = edge[i].v;
if(dist[e] < edge[i].value + dist[top])
{
dist[e] = edge[i].value + dist[top];
if(!visited[e])
{
Q.push(e);
visited[e] = true;
}
}
}
}
}

int main()
{
freopen("in.txt", "r", stdin);
while (scanf("%d", &n) != EOF)
{
init();
SPFA(MIN);
printf("%d\n", dist[MAX]);
//print();
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: