您的位置:首页 > 其它

HDOJ 1063 Exponentiation

2013-05-21 19:08 260 查看


Exponentiation

Time Limit: 1000/500 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5340 Accepted Submission(s): 1447



Problem Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12


Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


Source

East Central North America 1988

Recommend

PrincetonBoy

一开始以为是一道简单题,实际上也是一道简单题,只是要注意的细节很多

001.00 2 1

000.12 2 .0144

***** 0 1

01.10 2 1.21

10 2 100 (我被这个卡住了,囧)

#include <iostream>
#include <cstring>
#include <string>
using namespace std;
const int MAX=2000;
string sa;
int a[MAX],b[MAX],c[MAX];
int ib,i,j,la;

void mul(const int a[],const int b[],int c[]);
int main(int argc, char *argv[])
{
while (cin>>sa>>ib){
if (!ib){
cout<<"1\n";
continue;
}
memset(a,sizeof(a),0);
memset(b,sizeof(b),0);
memset(c,sizeof(c),0);
la=sa.find('.');
while (la!=-1 && sa[sa.size()-1]=='0') sa.erase(sa.size()-1,1);
while (sa[0]=='0') sa.erase(0,1);
a[0]=sa.size();
la=sa.find('.');
if (la!=-1){
a[0]--;
sa.erase(la,1);
la=a[0]-la;
}
if (!a[0]){
cout<<"0\n";
continue;
}
c[0]=a[0];
for (i=1;i<=a[0];++i){
a[i]=sa[a[0]-i]-'0';
c[i]=sa[c[0]-i]-'0';
}
for (i=1;i<ib;++i){
for (j=0;j<=c[0];++j) b[j]=c[j];
memset(c,0,sizeof(c));
mul(a,b,c);
}

if (la!=-1){
la*=ib;
if (la>=c[0]){
la-=c[0]; cout<<'.';
for (i=0;i<la;++i) cout<<'0';
for (i=c[0];i;--i) cout<<c[i];
}
else{
for (i=c[0];i>la;--i) cout<<c[i];
if (i) cout<<'.';
for (i=la;i;--i) cout<<c[i];
}
}
else{
for (i=c[0];i;--i) cout<<c[i];
}
cout<<endl;
}
return 0;
}

void mul(const int a[],const int b[],int c[]){
int i,j,len;
for (i=1;i<=a[0];++i)
for (j=1;j<=b[0];++j){
c[i+j-1]+=a[i]*b[j];
c[i+j]+=c[i+j-1]/10;
c[i+j-1]%=10;
}
len=a[0]+b[0];
while (len && !c[len]) len--;
c[0]=len;
if (0==c[0]) c[0]++;
return;
}


kdwycz的网站: http://kdwycz.com/

kdwyz的刷题空间:http://blog.csdn.net/kdwycz
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: