您的位置:首页 > 其它

HDU 3342 Legal or Not 判断拓补排序能否形成环

2013-05-21 16:59 225 查看
点击打开链接
 

Legal or Not

[b]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2791    Accepted Submission(s): 1261
[/b]

[align=left]Problem Description[/align]
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When
someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are
too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian
is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.
 

 
[align=left]Input[/align]
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which
means x is y's master and y is x's prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 
[align=left]Output[/align]
For each test case, print in one line the judgement of the messy relationship.

If it is legal, output "YES", otherwise "NO".
 

 
[align=left]Sample Input[/align]

3 2
0 1
1 2
2 2
0 1
1 0
0 0

 

 
[align=left]Sample Output[/align]

YES
NO

 

 
[align=left]Author[/align]
QiuQiu@NJFU
 

 
[align=left]Source[/align]
HDOJ Monthly Contest – 2010.03.06
[align=left] [/align]
[align=left] [/align]

题意:a是b的老师,b是c的老师,那么a是c的老师。如果a是b的老师,b是c的老师 ,c是a的老师,这样是不合法的。

思路:拓补排序。

 

#include<stdio.h>
#include<string.h>
int n,m,i,j,k;
int map[107][107],in[107];
void print()
{
int cnt=0;
for(i=0;i<n;i++)
{

for(j=0;j<n;j++)
{
if(!in[j])
{
in[j]--;
cnt++;
for(k=0;k<n;k++)
if(map[j][k])
in[k]--;
break;
}
}
if(j==n)
{
printf("NO\n");
return;
}

}
if(cnt==n)printf("YES\n");
else printf("NO\n");
}
int main()
{
while(scanf("%d%d",&n,&m),n)
{
memset(map,0,sizeof(map));
memset(in,0,sizeof(in));
int a,b;
while(m--)
{
scanf("%d%d",&a,&b);
if(!map[a][b])
{
map[a][b]=1;
in[b]++;
}
}
print();
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: