您的位置:首页 > 其它

HDU 1020

2013-05-19 23:11 155 查看


Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20395 Accepted Submission(s): 8819



Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC


Sample Output

ABC
A2B3C


Author

ZHANG Zheng

Recommend

JGShining

注意下字符的保留以及计数问题

代码:
#include<stdio.h>
#include<string.h>
char str[10001];
int main()
{
int n,i,count,k,len;
while(scanf("%d%*c",&n)!=EOF)
{
while(n--)
{
gets(str);
len=strlen(str);
for(i=0,count=1;i<len;i++)
{
if(str[i]==str[i+1])
count++;
else
{    if(count!=1)
{
printf("%d%c",count,str[i]);
count=1;
}
else
{
printf("%c",str[i]);
count=1;
}
}
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: