您的位置:首页 > 编程语言 > Java开发

Java BeansZOJ Problem Set - 3714 the 10th 浙江ACM赛

2013-05-12 15:56 363 查看
Java Beans
Time Limit: 2 Seconds
Memory Limit: 65536 KB
There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to selectM kids who seated in
M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get fromM consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) andM (1 ≤
M ≤ N). Here N and M are defined in above description. The second line of each test case containsN integers
Ci (1 ≤ Ci ≤ 1000) indicating number of java beans theith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75

Sample Output

16
158


#include<stdio.h>
int main()
{
int T,N,M,i,j;
int arr[440];
int max=-1,sum;
scanf("%d",&T);

while(T--)
{sum=0;max=-1;

scanf("%d%d",&N,&M);
for(i=0;i<N;i++)
{	scanf("%d",&arr[i]);
arr[i+N]=arr[i];
}
for(i=0;i<N;i++)
{sum=0;
for(j=i;j<i+M;j++)
sum+=arr[j];
if(sum>max)
max=sum;
}
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  算法