您的位置:首页 > 其它

POJ 2481 Cows

2013-05-08 22:20 190 查看
题目链接 : POJ2481

[align=center]Cows[/align]

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 9715 Accepted: 3183
Description
Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei -
Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!
Input
The input contains multiple test cases.

For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105)
specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.
Output
For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input
3
1 2
0 3
3 4
0

Sample Output
1 0 0

Hint
Huge input and output,scanf and printf is recommended.
Source
POJ Contest,Author:Mathematica@ZSU
 

还是树状数组。。只不过要自己排序

 

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
#include<set>
#include<queue>
using namespace std;

int num[100005][2];
int index[100005],ans[100005];
int bit[131075];
int n;
bool cmp(int a,int b)
{
if(num[a][0]==num[b][0]) return num[a][1]>num[b][1];
return num[a][0]<num[b][0];
}
void updat(int x,int v)
{
while(x<131074)
{
bit[x]+=v;
x+=x&-x;
}
}
int query(int x)
{
int s=0;
while(x)
{
s+=bit[x];
x-=x&-x;
}
return bit[131072]-s;
}
int main()
{
while(scanf("%d",&n))
{
if(n==0) break;
memset(bit,0,sizeof(bit));
for(int i=0;i<n;i++)
scanf("%d%d",&num[i][0],&num[i][1]),index[i]=i;
sort(index,index+n,cmp);
for(int i=0;i<n;i++)
{
if(i && num[index[i]][0]==num[index[i-1]][0] && num[index[i]][1]==num[index[i-1]][1])
ans[index[i]]=ans[index[i-1]];
else ans[index[i]]=query(num[index[i]][1]);
updat(num[index[i]][1]+1,1);
}
for(int i=0;i<n;i++)
if(i) printf(" %d",ans[i]);
else printf("%d",ans[0]);
putchar(10);
}
return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: