您的位置:首页 > 其它

USACO 1.2.1 Milking Cows

2013-05-03 23:43 337 查看
Milking Cows

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins
at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between
the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).
Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):
The longest time interval at least one cow was milked.
The longest time interval (after milking starts) during which no cows were being milked.

PROGRAM NAME: milk2

INPUT FORMAT

Line 1:The single integer
Lines 2..N+1:Two non-negative integers less than 1000000, the starting and ending time in seconds after 0500

SAMPLE INPUT (file milk2.in)

3
300 1000
700 1200
1500 2100

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

SAMPLE OUTPUT (file milk2.out)

900 300

很简单的区间覆盖 , 问题不大。

/*
ID: xinming2
PROG: milk2
LANG: C++
*/
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
using namespace std;
struct people
{
int timea;
int timeb;
}a[5500];
bool cmp(people a , people b)
{
if(a.timea == b.timea)
{
return a.timeb < b.timeb;
}
return a.timea < b.timea;
}
int main()
{

freopen("milk2.in","r",stdin);
freopen("milk2.out","w" , stdout);
int n , i ;
while(scanf("%d",&n)!=EOF)
{
for( i = 0 ; i < n ; i++)
{
scanf("%d%d",&a[i].timea , &a[i].timeb);
}
sort(a , a + n , cmp);
int have = 0 , maxnone = 0 , none = 0;
int start = a[0].timea, end = a[0].timeb ;
int maxhave = end - start;
for(i = 0 ; i < n ;i++)
{
if(end >= a[i].timea)
{
end = max(end , a[i].timeb);
have = end - start;
maxhave = max(have , maxhave);
}
else
{
none = a[i].timea - end;
maxnone = max(none , maxnone);
start = a[i].timea;
end = a[i].timeb;
have = end - start;
maxhave = max(have , maxhave);

}

}
printf("%d %d\n",maxhave , maxnone);
}
return 0;
}
/*

*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 水题