您的位置:首页 > 其它

A + B Problem II

2013-05-03 21:15 155 查看

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 156078 Accepted Submission(s): 29544



[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110 [code]/*
大数相加
*/

#include<iostream>
#include<cstdio>
using namespace std;
void reve(char a[]){
char b[1002];
int j=0;
memcpy(b,a,strlen(a)+1);
for(int i=strlen(b)-1;i>=0;i--){
*(a+j)=b[i];
j++;
}
}
int main()
{
int t,count=1,tag=0;
cin>>t;
while(t--){
if(tag)
cout<<endl;
char a[1002],b[1002],c[1005];
char a1[1002],b1[1002];
memset(c,'0',sizeof(c));
cin>>a>>b;
memcpy(a1,a,strlen(a)+1);
memcpy(b1,b,strlen(b)+1);
reve(a);
reve(b);
int lena=strlen(a),lenb=strlen(b);
int max=lena>lenb?lena:lenb,i,j;
for(i=0;i<max;i++){
if(i>=lena)
a[i]='0';
if(i>=lenb)
b[i]='0';
}
a[i]='\0';
b[i]='\0';
int sum=0,num=0,k=0;
for(i=0;i<max;i++){
sum=a[i]-'0'+b[i]-'0';
c[k++]=(sum+num)%10+'0';
num=(sum+num)/10;
}
c[k]='\0';
cout<<"Case "<<count++<<":"<<endl;
cout<<a1<<" + "<<b1<<" = ";
reve(c);
for(i=0;i<k;i++)
if(c[i]!='0')
break;
int flag=0;
for(j=i;j<k;j++){
flag=1;
cout<<c[j];
}
if(!flag)
cout<<"0";
cout<<endl;
tag=1;
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: