您的位置:首页 > 其它

hdu 1009 FatMouse' Trade

2013-05-02 18:47 351 查看

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31290 Accepted Submission(s): 10104


[align=left]Problem Description[/align]
FatMouse
prepared M pounds of cat food, ready to trade with the cats guarding
the warehouse containing his favorite food, JavaBean.
The warehouse
has N rooms. The i-th room contains J[i] pounds of JavaBeans and
requires F[i] pounds of cat food. FatMouse does not have to trade for
all the JavaBeans in the room, instead, he may get J[i]* a% pounds of
JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real
number. Now he is assigning this homework to you: tell him the maximum
amount of JavaBeans he can obtain.

[align=left]Input[/align]
The
input consists of multiple test cases. Each test case begins with a
line containing two non-negative integers M and N. Then N lines follow,
each contains two non-negative integers J[i] and F[i] respectively. The
last test case is followed by two -1's. All integers are not greater
than 1000.

[align=left]Output[/align]
For
each test case, print in a single line a real number accurate up to 3
decimal places, which is the maximum amount of JavaBeans that FatMouse
can obtain.

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

[align=left]Sample Output[/align]

13.333
31.500
题意:有 m 的猫粮,和n中交换 f[i] 能换 j[i]
求出能交换得的最大值,
按他们交换比值进行排序
然后计算出最值

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

#define N 1005

typedef struct numb
{
int j,f;
double p;
numb()
{
j = 0;
f = 0;
p = 0.0;
}
}numb;

numb a
;

bool fun(numb x,numb y)
{
if(x.p - y.p > 0.000001)
return true;
else return false;
}
int main()
{
int m,n;
while(scanf("%d%d",&m,&n) && n != -1 && m != -1)
{
int i;
for(i = 0; i < n; i++)
{
scanf("%d%d",&a[i].j,&a[i].f);
a[i].p = 1.0*a[i].j/a[i].f;
}
sort(a,a+n,fun);
/*for(i = 0; i < n; i++)
printf("%lf  ",a[i].p);*/

double sum = 0.0;
int j;
int k = 0;
int flag = 0;
for(i = 0; i < n; i++)
{
if(m >= a[i].f)
{
sum += a[i].j;
m -= a[i].f;
}
else
{
sum += a[i].p*m;
break;
}
}
printf("%0.3lf\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: