您的位置:首页 > 其它

UVA 357 Let Me Count The Ways Problem(动态规划 硬币)

2013-04-30 14:46 387 查看
Let Me Count The Ways
After making a purchase at a large department store, Mel's change was 17 cents. He received 1 dime, 1 nickel, and 2 pennies. Later that day, he was shopping at a convenience store. Again his change was 17 cents. This time he received 2 nickels and 7 pennies. He began to wonder ' "How many stores can I shop in and receive 17 cents change in a different configuration of coins? After a suitable mental struggle, he decided the answer was 6. He then challenged you to consider the general problem.

Write a program which will determine the number of different combinations of US coins (penny: 1c, nickel: 5c, dime: 10c, quarter: 25c, half-dollar: 50c) which may be used to produce a given amount of money.

Input

The input will consist of a set of numbers between 0 and 30000 inclusive, one per line in the input file.

Output

The output will consist of the appropriate statement from the selection below on a single line in the output file for each input value. The number m is the number your program computes, n is the input value.

There are m ways to produce n cents change.

There is only 1 way to produce n cents change.

Sample input

17
11
4

Sample output

There are 6 ways to produce 17 cents change.
There are 4 ways to produce 11 cents change.
There is only 1 way to produce 4 cents change.

此题和 Coins change 类似,几乎是同一道题,但是呢,这个题让人郁闷的是在处理格式上。求支付一定面额有多少种方法。

注意点一个是输出要long long,一个是如果结果只有一种方法,输出格式跟其他的不同,在一点就是一定要切记,不要在最后位输出空格,即使你直接拷贝过来时后面有一个空格

还有,用滚动数组提交的时间是19ms,用母函数模板提交的是:463ms,孰优孰劣,显而易见

View Code

#include <iostream>
#include <cstdio>

using namespace std;
# define maxn 30002

long long  num[maxn];
long long  cent[6]={0,1,5,10,25,50};

int main()
{
int i,t;
long long  n;
for( i=1;i<=maxn;i++)
num[i]=0;
num[0]=1;

for(t=1;t<=5;t++)
for(i=1;i<=maxn;i++)
{
if(i>=cent[t]) num[i]+=num[i-cent[t]];//  状态转移方程
}
while(scanf("%lld",&n)!=EOF)
{
if(num
==1)
printf("There is only 1 way to produce %d cents change.\n",n);
else
printf("There are %lld ways to produce %lld cents change.\n",num
,n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: