您的位置:首页 > 其它

hdu 1080 Human Gene Functions (dp)

2013-04-29 00:11 375 查看

Human Gene Functions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1646    Accepted Submission(s): 928


[align=left]Problem Description[/align]
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining
their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in
determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes
and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that
the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score
the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G

-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG

-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

 

[align=left]Input[/align]
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The
length of each gene sequence is at least one and does not exceed 100.

 

[align=left]Output[/align]
The output should print the similarity of each test case, one per line.

 

[align=left]Sample Input[/align]

2
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA

 

[align=left]Sample Output[/align]

14
21

 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define p(i,j)   p[d[i]][d[j]]
int f[110][110];
int p[6][6]={
0,0,0,0,0,0,
0,5,-1,-2,-1,-3,
0,-1,5,-3,-2,-4,
0,-2,-3,5,-2,-2,
0,-1,-2,-2,5,-1,
0,-3,-4,-2,-1,-1000000,
};
int d[130];
void dp(int len1,const char *a,int len2,const char *b){
int i,j;
memset(f,0,sizeof(f));
for(i=1;i<=len1;i++)
f[i][0]=f[i-1][0]+p(a[i],'-');//只与空格匹配
for(i=1;i<=len2;i++)
f[0][i]=f[0][i-1]+p('-',b[i]);//只与空格匹配
for(i=1;i<=len1;i++)
for(j=1;j<=len2;j++){
f[i][j]=max(f[i-1][j]+p(a[i],'-'),f[i][j-1]+p('-',b[j]));////只与空格匹配
f[i][j]=max(f[i][j],f[i-1][j-1]+p(a[i],b[j]));//a,b匹配
}
printf("%d\n",f[len1][len2]);
}
int main(){
d['A']=1;d['C']=2;d['G']=3;d['T']=4;d['-']=5;
char a[110],b[110];
int T,n,m;
cin>>T;
while(T--){
scanf("%d%s%d%s",&n,a+1,&m,b+1);
dp(n,a,m,b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: