您的位置:首页 > 其它

hdu1525 Euclid's Game 找规律

2013-04-26 21:17 381 查看


Euclid's Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1095 Accepted Submission(s): 501



Problem Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then
Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with
(25,7):

25 7

11 7

4 7

4 3

1 3

1 0

an Stan wins.



Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.



Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.



Sample Input

34 12
15 24
0 0




Sample Output

Stan wins
Ollie wins
给出两个数,m和n,将大的数减去小的数的倍数,但得到的数要是非负数,使最终有一个数为0的话就胜了。
思路:当m/n=1时,只有一种路线,若两个玩家足够聪明,他们就知道这样下去谁会赢,然而谁到了m/n>=2这种局面,谁就可以选择走多少步到达m/n=1这种局面,也就是说谁到了m/n>=2这种局面谁就一定能赢。如果一开始给出m/n=1这种局面,循环下去就知道是谁赢了。
#include <iostream>  
#include <cstring>  
#include <cstdio>  
  
using namespace std;  
int main()  
{  
    int m,n;  
    while(cin>>m>>n)  
    {  
        if(!m&&!n) break;  
        int cnt=0;  
        while(1)  
        {  
            if(m<n) swap(m,n);  
            if(n==0||m==0||m%n==0||m/n>=2) { cnt++ ;break; }     // 遇到m%n==0 ,操作一步,变m=0或n=0;  遇到m/n>=2,说明是Stan遇到的,所以cnt++;  
            m%=n;  
            cnt++;  
        }  
        if(cnt%2==1)       //  cnt奇数说明最后最后操作或遇见必胜情况的人是Stan ,
        cout<<"Stan wins"<<endl;  
        else  
        cout<<"Ollie wins"<<endl;  
  
  
    }  
   return 0;  
  
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: