您的位置:首页 > 其它

hdu 1701

2013-04-26 10:50 281 查看

ACMer

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2994 Accepted Submission(s): 1348



[align=left]Problem Description[/align]
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?

[align=left]Input[/align]
The input contains multiple test cases.

The first line has one integer,represent the number of test cases.

The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.

[align=left]Output[/align]
For each test case, output the minumal number of students in HDU.

[align=left]Sample Input[/align]

1
13.00 14.10


[align=left]Sample Output[/align]

15


[align=left]Source[/align]
2007省赛集训队练习赛(1)

[align=left]Recommend[/align]
lcy

//ACMer人数在P%和Q%之间,那么P%的人与Q%的人就不能相同,因为一个是至少,一个是至多。另外注意浮点数的陷阱。
#include <stdio.h>
#define PI 3.1415926
int main()
{
int n, i;
double p, q;
scanf("%d", &n);
while(n--)
{
scanf("%lf%lf", &p, &q);
for(i = 0; ; i++)
if((int)(i * p / 100) < (int)(i * q / 100))
{
printf("%d\n", i);
break;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: