您的位置:首页 > 其它

Wiskey's Power+数学题

2013-04-25 13:38 495 查看

Wiskey's Power

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 326 Accepted Submission(s): 153



[align=left]Problem Description[/align]
Come back school from the 33rdACM / ICPC Asia ChenDu, everyone is exhausted, in particular the captain Wiskey. As saying that night, Wiskey drink a lot of wine, just as he blurred, fall to sleep. All of a sudden, Wiskey
felt a slight discomfort in the chest, and then vomiting, vomitted all over. The next day, Wiskey is extremely sluggish, vomit still on the train.



Your task is to calculate the coordinates of vomit.

We assume that the quality of vomit is m, and its size can be ignored.

As the figure below:



The vomit start from the blue point A, whose speed is V, and its angle with X-axis is a. If the vomit hit the ceiling, then its value of the speed don't changed and if before the collision the angle of the speed with X-axis is b, then after the collision the
angle of the speed with X-axis is b , too.

Ignore air resistance, acceleration due to gravity g = 9.87m/s2, calculate and output Q.

(you can assume that the vomit will not fall to the higher berth)

[align=left]Input[/align]
Each line will contain three numbers V , m and a (0 <= a < 90)described above.

Process to end of file.

[align=left]Output[/align]
For each case, output Q in one line, accurate up to 3 decimal places.

[align=left]Sample Input[/align]

100 100 45


[align=left]Sample Output[/align]

3.992 [code]#include<stdio.h>
#include<math.h>
#define g 9.87
#define s0 3
#define s1 0.5
#define s2 3.5
void main()
{
double v,a,vx,vy,q,m;
while(scanf("%lf %lf %lf",&v,&m,&a)!=EOF)
{
vy=sin(a*3.1415926/(180))*v;
vx=cos(a*3.1415926/(180))*v;
if(vy*vy/(2*g)>s1)
q=(sqrt(2*g*(s2-s1)+vy*vy)+vy-2*sqrt(vy*vy-2*g*s1))/g*vx;
else q=(vy+sqrt(2*g*s0+vy*vy))/g*vx;
printf("%.3f\n",q);
}
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: