您的位置:首页 > 其它

An easy problem+数学推理

2013-04-25 12:05 302 查看

An easy problem

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4575 Accepted Submission(s): 1117



[align=left]Problem Description[/align]
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..



One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

[align=left]Input[/align]
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 1010).

[align=left]Output[/align]
For each case, output the number of ways in one line.

[align=left]Sample Input[/align]

2
1
3


[align=left]Sample Output[/align]

0
1思路:数学推理 [code]#include<stdio.h>
#include<math.h>
int main()
{
int n,k;
__int64 i,j,m;
scanf("%d",&n);
while(n--)
{
scanf("%I64d",&m);
m=m+1;
j=sqrt(m);
k=0;
for(i=2;i<=j;i++)
{
if(m%i==0)
k++;
}
printf("%d\n",k);
}
return 0;
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: