您的位置:首页 > 其它

poj 2318 计算几何叉积

2013-04-24 19:08 435 查看
TOYS

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 8420Accepted: 4007
Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the
toys get mixed up, and it is impossible for John to find his favorite toys.

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example
toy box.




For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner
and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that
the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is
random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the
rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>
using namespace std;

struct point{int x,y;};

struct node{point a,b;}vis[5555];

int num[5555];

int judge(point p1,point p2,point p0)
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y);
}

void Search(point a,int n)
{
    int l,r,mid;
    l=0;r=n-1;
    while(l<r)
    {
        mid=(l+r)>>1;
        if(judge(a,vis[mid].a,vis[mid].b)>0)
            l=mid+1;
        else
            r=mid;
    }
    if(judge(a,vis[l].a,vis[l].b)<0)
        num[l]++;
    else
        num[l+1]++;
}

int main()
{
    int n,m,x1,x2,y1,y2;
    while(cin>>n&&n)
    {
        int i,z1,z2;
        point a;
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        memset(vis,0,sizeof(vis));
        memset(num,0,sizeof(num));
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&z1,&z2);
            vis[i].a.x=z1;
            vis[i].a.y=y1;
            vis[i].b.x=z2;
            vis[i].b.y=y2;
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&a.x,&a.y);
            Search(a,n);
        }
        for(i=0;i<=n;i++)
            printf("%d: %d\n",i,num[i]);
        printf("\n");
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: