您的位置:首页 > 其它

Tell me the area

2013-04-23 12:54 323 查看

Tell me the area

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1381 Accepted Submission(s): 430



[align=left]Problem Description[/align]
There are two circles in the plane (shown in the below picture), there is a common area between the two circles. The problem is easy that you just tell me the common area.



[align=left]Input[/align]
There are many cases. In each case, there are two lines. Each line has three numbers: the coordinates (X and Y) of the centre of a circle, and the radius of the circle.

[align=left]Output[/align]
For each case, you just print the common area which is rounded to three digits after the decimal point. For more details, just look at the sample.

[align=left]Sample Input[/align]

0 0 2
2 2 1


[align=left]Sample Output[/align]

0.108


[align=left]Author[/align]
wangye

[align=left]Source[/align]
2008 “Insigma International Cup” Zhejiang Collegiate Programming
Contest - Warm Up(4)

[align=left]Recommend[/align]
wangye
#include<stdio.h>
#include<math.h>
int main()
{
double q,w,m,n,a,b,c,x,y,z,PI;
PI=2*asin(1.0);
while(~scanf("%lf%lf%lf",&a,&b,&c)){
scanf("%lf%lf%lf",&x,&y,&z);
a=sqrt((a-x)*(a-x)+(b-y)*(b-y));//计算圆心距
//如果两圆相离、外切或至少一圆半径为0时,那么所求面积为0
if(a>=c+z||!c||!z)x=0;
//如果两内切或内含,那么所求面积为小圆面积
else if(a<=fabs(z-c)){
if(z>c)z=c;
x=z*z*PI;
}
//如果两圆相交,面积求解如下
else{
//由余弦定理求出公共弦在圆o1中对应的圆心角的一半
b=acos((a*a+c*c-z*z)/(2*a*c));
//由余弦定理求出公共弦在圆o2中对应的圆心角的一半
y=acos((a*a+z*z-c*c)/(2*a*z));
//计算圆o1中扇形面积
m=b*c*c;
//计算圆o2中扇形面积
n=y*z*z;
//计算圆o1中扇形所对应的三角形面积
q=c*c*sin(b)*cos(b);
//计算圆o2中扇形所对应的三角形面积
w=z*z*sin(y)*cos(y);
//q+w为图中四边形面积,两扇形面积之和与四边形面积之差即为
//所求面积。在图2中y为钝角,计算出的面积w为负值,这时q+w
//表示两三角面积之差,刚好还是四边形面积,因此对于图1和图
//2不必分情况讨论
x=m+n-(q+w);
}
printf("%.3f\n",x);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: