您的位置:首页 > 其它

Can you find it?+合并字串+二分查找

2013-04-18 20:07 295 查看

Can you find it?

Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)

Total Submission(s): 7114 Accepted Submission(s): 1851



[align=left]Problem Description[/align]
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

[align=left]Input[/align]
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent
the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

[align=left]Output[/align]
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

[align=left]Sample Input[/align]

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10


[align=left]Sample Output[/align]

Case 1:
NO
YES
NO


[align=left]Author[/align]
wangye

[align=left]Source[/align]
HDU 2007-11 Programming Contest

[align=left]Recommend[/align]
威士忌

/*
思路:二分查找
技巧:合并其中两个串,再进行二分,不然超时
*/

#include<iostream>
using namespace std;
int d[250010];
int cmp(const void *a,const void *b){
return *(int *)a-*(int *)b;
}
int main()
{
int l,n,m,count=1;
while(cin>>l>>n>>m){
int a[502],b[502],c[502];
int i,j;
for(i=0;i<l;i++)
cin>>a[i];
for(i=0;i<n;i++)
cin>>b[i];
for(i=0;i<m;i++)
cin>>c[i];
int k=0;
for(i=0;i<n;i++)
for(j=0;j<m;j++)
d[k++]=b[i]+c[j];

qsort(d,k,sizeof(d[0]),cmp);
int s;
cin>>s;
cout<<"Case "<<count++<<":"<<endl;
while(s--){
int x,flag=0;
cin>>x;
for(i=0;i<l;i++){
int num=x-(a[i]);
int low=0,high=k,mid;
while(low<=high){
mid=(low+high)/2;
if(d[mid]<num)
low=mid+1;
else
{
if(d[mid]==num)
break;
else
high=mid-1;
}
}
if(num==d[mid]){
flag=1;
cout<<"YES"<<endl;
break;
}
}
if(!flag)
cout<<"NO"<<endl;
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: