您的位置:首页 > 其它

POJ 1861 Network (并查集的应用,kruskal)

2013-04-14 23:08 363 查看
                                                                              
Network

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 11361Accepted: 4330Special Judge
Description
Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other
using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).

Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input
The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <=
15000). All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not
exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output
Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables
used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input
4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output
1
4
1 2
1 3
2 3
3 4

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define SIZE 1500

using namespace std;

struct Node
{
int s,e,v;
}edge[SIZE*100+1];

int n,m,maxi,all,idx;
int fat[SIZE];
int vis[SIZE*100+1];

bool cmp(Node a,Node b)
{
return a.v < b.v;
}

int find(int x)
{
if(x != fat[x])
fat[x]= find(fat[x]);
return fat[x];
}

bool combine(int x,int y)
{
int tx = find(x);
int ty = find(y);
if(tx != ty)
{
fat[tx] = ty;
return true;
}
return false;
}

void kruskal()
{
int s,e,v;
for(int i=1; i<=m; i++)
{
s = edge[i].s;
e = edge[i].e;
v = edge[i].v;
if(combine(s,e))
{
if(maxi < v)
maxi = v;
vis[++idx] = i;
all ++;
}
}
}

int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=1; i<=n; i++)
fat[i] = i;
for(int i=1; i<=m; i++)
scanf("%d%d%d",&edge[i].s,&edge[i].e,&edge[i].v);
sort(edge+1,edge+1+m,cmp);
memset(vis,0,sizeof(vis));
maxi = all = idx = 0;
kruskal();
printf("%d\n",maxi);
printf("%d\n",all);
for(int i=1; i<=idx; i++)
printf("%d %d\n",edge[vis[i]].s,edge[vis[i]].e);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: