您的位置:首页 > 其它

POJ_1002 487-3279

2013-04-13 21:10 316 查看
[align=center]487-3279[/align]

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 209902Accepted: 36575
Description
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP.
Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could
order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers
in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number
appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3


一开始想到输入数据极限会有10万个,加上需要字符串的处理,所以选择建立一个长度为10万的long数组,对每个输入数据进行字符串到long的转换,快排,根据题目要求输出...最后发现超时了...其实根据题目要求,统计出现次数大于2的号码数...其实字符串的转换时必要的,所以应该选择更为好的排序算法...计数排序...定义了一个七维数组...下表分别为0-9....字符串转换后直接在对应下标进行定位自加。最后根据大于二输出即可...具体代码如下:

#include<iostream>
#include<string>
#define SIZE 100025
#define NUM num[10][10][10][10][10][10][10]
using namespace std;

long num[10][10][10][10][10][10][10];
int main()
{
long n,i,j,k,a0,a1,a2,a3,a4,a5,a6;
char ph[10];
bool res;
string tmp;

cin >> n;

for(a0 = 0; a0 <= 9; a0++)
for(a1 = 0; a1 <= 9; a1++)
for(a2 = 0; a2 <= 9; a2++)
for(a3 = 0; a3 <= 9; a3++)
for(a4 = 0; a4 <= 9; a4++)
for(a5 = 0; a5 <= 9; a5++)
for(a6 = 0; a6 <= 9; a6++)
num[a0][a1][a2][a3][a4][a5][a6] = 0;

for(i = 1; i <= n; i++)
{
cin >> tmp;
k = 0;
//处理输入的字符串...
for(j = 0; j < tmp.length(); j++)
{
if(tmp[j] >= '0' && tmp[j] <= '9')
{
ph[k] = tmp[j] - '0';
k++;
}
else if(tmp[j] != '-')
{
switch(tmp[j])
{
case 'A':
case 'B':
case 'C':
ph[k] = 2;
k++;
break;
case 'D':
case 'E':
case 'F':
ph[k] = 3;
k++;
break;
case 'G':
case 'H':
case 'I':
ph[k] = 4;
k++;
break;
case 'J':
case 'K':
case 'L':
ph[k] = 5;
k++;
break;
case 'M':
case 'N':
case 'O':
ph[k] = 6;
k++;
break;
case 'P':
case 'R':
case 'S':
ph[k] = 7;
k++;
break;
case 'T':
case 'U':
case 'V':
ph[k] = 8;
k++;
break;
case 'W':
case 'X':
case 'Y':
ph[k] = 9;
k++;
break;
default:
break;
}

}

}

num[ ph[0] ][ ph[1] ][ ph[2] ][ ph[3] ][ ph[4] ][ ph[5] ][ ph[6] ]++;
}

res = true;
for(a0 = 0; a0 <= 9; a0++)
for(a1 = 0; a1 <= 9; a1++)
for(a2 = 0; a2 <= 9; a2++)
for(a3 = 0; a3 <= 9; a3++)
for(a4 = 0; a4 <= 9; a4++)
for(a5 = 0; a5 <= 9; a5++)
for(a6 = 0; a6 <= 9; a6++)
if(num[a0][a1][a2][a3][a4][a5][a6] > 1)
{
res = false;
cout << a0 << a1 << a2 << "-" << a3 << a4 << a5 << a6 << " " << num[a0][a1][a2][a3][a4][a5][a6] << endl;
}

if(res)
cout << "No duplicates." <<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: